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Thank you for purchasing the Smart
Loader Package SLP-C20/30 for Digital
Indicating Controller SDC20/21, SDC30/31.
This manual contains information for
ensuring correct use of the SLP-C20/30.
It also provides necessary information
for installation, maintenance, and trou-
bleshooting.
This manual should be read by those
who design and maintain devices that
use the SLP-C20/30. 
Be sure to keep this manual nearby for
handy reference.



This product has been designed, developed and manufactured for general-purpose
application in machinery and equipment.
Accordingly, when used in applications outlined below, special care should be taken to
implement a fail-safe and/or redundant design concept as well as a periodic
maintenance program.

• Safety devices for plant worker protection
• Start/stop control devices for transportation and material handling machines
• Aeronautical/aerospace machines
• Control devices for nuclear reactors

Never use this product in applications where human safety may be put at risk.

RESTRICTIONS ON USE

The DIGITRONIK® is registered trademarks of Yamatake Corpration.
Other company names and product names listed in this manual are registered
trademarks or trademarks of respective companies.

REQUEST

©2001 Yamatake Corporation ALL RIGHTS RESERVED

Ensure that this User's Manual is handed over to the user before the
product is used. 

Copying or duplicating this User's Manual in part or in whole is forbid-
den. The information and specifications in this User's Manual are sub-
ject to change without notice.

Considerable effort has been made to ensure that this User's Manual is
free from inaccuracies and omissions. 
If you should find any inaccuracies or omissions, please contact
Yamatake Corporation.

In no event is Yamatake Corporation liable to anyone for any indirect,
special or consequential damages as a result of using this product.

Do not apply a strong force while connecting a loader plug. Failure to do
so might damage the instrument.

Handling Precautions
Application of excessive force to the loader plug might cause
communication failure. If such failure happens, reconnect the
loader plug correctly.

IMPORTANT



Unpacking
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Check the following items when removing the SLP-C20/C30 from its package:

1. Check the model No. to make sure that you have received the product that you ordered.

2. Check the SLP-C20/C30 for any apparent physical damage.

3. Check the contents of the package against the Package List to make sure that all accessories are included

in the package.

After unpacking, handle the SLP-C20/C30 and its accessories taking care to prevent damage or loss of parts.

If an inconsistency is found or the package contents are not in order, immediately contact your dealer.

Name Model No. Q'ty Remarks

System disk SLP-C20J20 for 1 Floppy disk
SDC20/21 3.5 inch disk (1.44MB)
SLP-C30J20 for
SDC30/31

Special cable - 1

User's Manual CP-UM-5161/E 1 This manual.
This manual is the common
manual of the SLP-C20 and
the SLP-C30.
The manual is written in both
Japanese and English.



The Role of This Manual
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In all, 5 manuals have been prepared for the SDC20/21, SDC30/31. Read the manual according to your specific

requirements.

The following lists all the manuals that accompany the SDC20/21, SDC30/31 and gives a brief outline of the

manual:

If you do not have the required manual, contact Yamatake Corporation or your dealer.

SDC20/21 Digital Indicating Controller User's Manual
Manual No.CP-UM-1470E

This manual is required reading for those who use the SDC20/21, those
who design hardware for integrating the SDC20/21 into operator control
panels, those who carry out maintenance, and those who operate instru-
ments in which the SDC20/21 is integrated.

It describes how to install and wire the SDC20/21 for integrating into instru-
ments, method of operation, maintenance and inspection, troubleshooting,
and hardware specifications.

SDC30/31 Digital Indicating Controller User's Manual
Manual No.CP-UM-1586E

This manual is required reading for those who use the SDC30/31, those
who design hardware for integrating the SDC30/31 into operator control
panels, those who carry out maintenance, and those who operate instru-
ments in which the SDC30/31 is integrated.

It describes how to install and wire the SDC30/31 for integrating into instru-
ments, method of operation, maintenance and inspection, troubleshooting,
and hardware specifications.

DIGITRONIK CPL Communications Manual SDC20/21
Manual No.CP-UM-1572E

The SDC20/21 can communicate with other equipment via the RS-485 or
RS-232C interfaces.

This manual is required reading for those who use the CPL communication
functions of the SDC20/21.
It briefly describes CPL communications, how to wire the SDC20/21,
communication procedures, communication data for the SDC20/21,
troubleshooting and communication specifications.

DIGITRONIK CPL Communications Manual SDC 30/31
Manual No.CP-UM-1589E

The SDC30/31 can communicate with other equipment via the RS-485
interfaces.

This manual is required reading for those who use the CPL communication
functions of the SDC30/31.
It briefly describes CPL communications, how to wire the SDC30/31,
communication procedures, communication data for the SDC30/31,
troubleshooting and communication specifications.
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Smart Loader Package SLP-C20/C30 for Digital Indicating Controller
SDC20/21, SDC30/31 User's Manual Manual No.CP-UM-5161E

This manual.
This manual is supplied with the Smart Loader Package SLP-C20/C30.
The manual describes the software used to make various settings for SLP-
C20/C30 using a personal computer. Personnel in charge of design or
setting of a system using SLP-C20/C30 must thoroughly read this manual.
The manual describes installation of the software into a personal computer,
operation of the personal computer, various functions, and setup
procedures.
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Organization of This User's Manual

This manual is organized as follows:

Chapter 1. INTRODUCTION
Be sure to read this chapter before you start using the Smart Loader Package.

This chapter describes the required operating environment for the personal

computer and briefly introduces its features.

Chapter 2. INSTALLATION AND BASIC FUNCTIONS
This chapter describes how to install, start up and quit the Smart Loader Package, its functions,

screen configurations and basic operations.

Chapter 3. OPERATION
This chapter describes how to operate the loader for setup and configuration of this software.

Chapter 4. TROUBLESHOOTING
This chapter describes error messages that are displayed when trouble occurs, and how to remedy

trouble.

Conventions Used in This Manual

The following conventions are used in this manual:

Handling Precautions :
Handling Precautions indicate items that the user should pay attention to
when handling the SLP-C20/C30.

Note : Notes indicate useful information that the user might benefit by knowing.

: This indicates the item or page that the user is requested to refer to.

(1), (2), (3) : The numbers with the parenthesis indicate steps in a sequence or indicate
corresponding parts in an explanation.

[OK] button : Indicates a selection button in screens displayed on the personal computer.

[Option] : Indicates messages and menus displayed on the personal computer.
[Type Setting]

[Option] → [Type Setting] :
Indicates the order to select the [Option] first and then select the
[Type Setting] displayed on the personal computer.

>> : Indicates the result of an operation, details displayed on the personal
computer or devices, or the state of a device after an operation.

[Ctrl] key, [X] key : Indicates keys on the keyboard.

[Ctrl]+[X] key : Indicates the operation of pressing the [X] key with the [Ctrl] key on the
keyboard held down.
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Chapter 1. INTRODUCTION
1  -  1 Outline of the SLP

The SLP-C20/C30 (simply called “SLP” from here on) is an engineering tool for the DigitroniK Line

SDC20/SDC30 Digital Indicating Controller (simply called “SDC” from here on).

The SLP runs on Windows95/98/Me/2000/XP (simply called "Windows" from here on) on a personal computer.

The SLP has the following functions:

1. Parameter setup

2. Communications with SDC (reading/writing of parameters)

3. File operations (reading/writing of parameters)

The SDC which can be set up with each SLP is as the follwing.

Note
• Install SLP on the hard disk following the procedure in “2-1 Installing SLP”.

Use the system disk that you have purchased as the backup system.

Handling Precautions
• These disks do not contain the system, and cannot be used as they are.

E1

Model No. of SLP Model No. of SDC

SLP-C20 SDC20/21

SLP-C30 SDC30/31



1  -  2 System Operating Environment
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The following system environment is required for using the SLP:

■ Hardware

* : Serial port

It is recommended to use a personal computer with 9-pin serial port built-in.

If your personal computer does not have any serial port, you may use any of

the extension adaptors listed below to connect the loader cable.

However, note that the operation may become unstable depending on the

personal computer environment.

• Special interface (port replicater)
Adaptor specially designed for each personal computer (special adaptor for

each personal computer model)

• CF card adaptor
CF232 manufactured by Elan Digital systems

URL: http://www.elandigitalsystems.com/interface/cf232.php

Operation confirmed personal computer, IBM's ThinkPad A31

REX-CF60 manufacture by RATOC.

URL: http://www.ratocsystems.com/products/subpage/cf60.html  (Japanese)

• USB adaptor
USB-RSAQ3 manufactured by I/O Data

URL: http://www.iodata.jp/prod/mobile/serial/2004/usb-rsaq3/  (Japanese)

Operation confirmed personal computer, IBM's ThinkPad A31

When connecting the USB cable, check the port No.

The port No. may vary depending on the USB cable connection position.

Handling Precautions
• Before using the print function, make sure that your printer can be

operated.

• Before starting up SLP, quit all other applications.
If you start up SLP while another application is running, SLP may
malfunction.

Item Description

Personal Computer Target model PC/AT compatibles with a Pentium chip or higher

Memory 32M byte or more

Operating system Windows95/98/Me/2000/XP

Peripheral Devices Display 800 X 600 dot or more, 16 bit color or more

Serial port 9-pin, serial port, 1ch or more *

Hard disk drive Hard disk with at least 40M byte of free space

Foppy disk drive At least 1 drive capable of reading the floppy disk in the
product package (1.44MB format)

Pointing device Windows-compatible mouse or equivalent device
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■ Hardware configuration *  Wiring example in communications with the SDC21.

■ Compatible equipment

SLP-C20

Reading/saving
Data disk

Communications
Cable (Accessory)

SDC21

Manufacturer Model No.

Dell OptiPlex Gxi5200

Dell OptiPlex GX5166

Fujitsu FMV-5166T3



Chapter 2. INSTALLATION AND BASIC FUNCTIONS

2  -  1 Installation, Starting Up and Quitting SLP
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This section describes how to install the SLP on a personal computer.

Handling Precautions
• If you start up the Installer while another application is running, the

Installer may malfunction.
Remove other resident applications from their directories before starting
up the Installer.
The SLP sometimes cannot be started up depending on the combination
of other applications and drivers.
For details on Windows and personal computer settings, refer to the
User’s Manuals provided with Windows and the personal computer.

● Installating SLP
1. Click the [Start]button at the bottom of the screen, and then click [Run...].
2. Enter the mesaage of [A:\setup].
3. Insert the disk provided with the software package into the disk drive, click

[OK]button.

>>The Installer is started.

4. Click [Next>]button.

Note
• To change the installation destination directory, click [Browse...]button.

5. Click [Next>]button.
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>>The following screen appears:

Note
• To change the program folder, enter the new folder name.

6. Click [Next>]button.

7. Click [Next>]button.

>>When installation ends normally, the following screen appears:

8. Click [Finish>]button.

>>The installer is finished.
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■ Starting up SLP
1. Click [Start]button at the bottom of the screen, and click the SLP-C❏❏

(SDC❏❏❏ ) under [Programs] → [SLP].
>>The SLP is started up, and the opening screen appears.

>>The menu window is displayed.

Note
For details on the operating system and the mouse you are using, refer to the

User’s Manual provided with Windows.

■ Quitting SLP
1. Click button at the top right of the screen.

The operation is the same by selecting the [File] → [Quit] command.

>>The following screen appears:

2. Click [OK]button.



2  -  2 Description of Functions

■ SLP functions
The SLP is provided with the following functions for configuring SDC functions:

• Parameter Editing Function

• File Management Function

• Data Communications Function

The figure below shows operations available by these functions.

Note
• “One file” refers to data for one SDC. Each file comprises the various

parameter settings and the model number information.

• Creates and edits parameters.

• Saves created data to a file on floppy disk or hard disk.
• Reads saved files for re-editing.

• Writes created data to the SDC.
• Reads from the SDC to the SLP.

Functions

Parameter Editing Function

File Management Function

Data Communications Function

E7



2  -  3 Screen Configuration
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■ SLP screen configuration

● Basic SLP screen

● Dialog box displayed when [Help] → [Version] is selected

Setup item

Menu bar
Tool bar

Selection window

Message window
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2 -  4 Menu Configuration List

■ SLP-C20

■ SLP-C30

Menu Icon Sub Menu 1 Sub Menu 2 Description Shortcut keys

File New Creates a new data Ctrl+N

Open Opens a existing file Ctrl+O

Save Saves the active data Ctrl+S

- Save As Saves the active data with a new name Ctrl+A
- CSV Out (X) Saves the active data in CSV format Ctrl+X
- Quit Quits the application Ctrl+Q

Communication Read (SDC20/21 to SLP) Reads the data from the device Ctrl+R

Write (SLP to SDC20/21) Writes the data to the device Ctrl+W

Setup - Standard SP/EV Displays the SP/EV. Ctrl+Shift+A
Parameters Displays the parameters Ctrl+Shift+B
Setup Displays the setup Ctrl+Shift+C

Option Type Setting Setting the type Ctrl+T

Environment Setting Setting the environment Ctrl+E

- Para Key Assignment Changes the para key assignment -

Help - Version Displays the version information -

Menu Icon Sub Menu 1 Sub Menu 2 Description Shortcut keys

File New Creates a new data Ctrl+N

Open Opens a existing file Ctrl+O

Save Saves the active data Ctrl+S

- Save As Saves the active data with a new name Ctrl+A
- CSV Out (X) Saves the active data in CSV format Ctrl+X
- Quit Quits the application Ctrl+Q

Communication Read (SDC20/21 to SLP) Reads the data from device Ctrl+R

Write (SLP to SDC20/21) Writes the data to the device Ctrl+W

Setup - Standard SP/EV Displays the SP/EV. Ctrl+Shift+A
PID Displays the PID Ctrl+Shift+B
Dist.control Pid Displays the disturbance control PID Ctrl+Shift+C
Parameters Displays the parameters Ctrl+Shift+D
Zone setting Displays the zone setting Ctrl+Shift+E
Setup Displays the setup Ctrl+Shift+F

Mode Mode Changes the Mode Ctrl+M
Option Type Setting Setting the type Ctrl+T

Environment Setting Setting the environment Ctrl+E

- UF Key Assignment Changes the UF Key assignment -

Help - Version Displays the version information -



Chapter 3. OPERATION
3  -  1 Setting Up Options

■ Setting the type
First, set the SLP type matched to the SDC model No.

1. Click icon.

The operation is the same by selecting the [Option] → [Type Setting]
command or the [Ctrl]+[T]keys.

>>The Type Setting dialog box appears.

2. Set the basic model No., output type control mode and option.

3. Select the desired setting from each of the selection items.

4. Click [ Finish]button.

Handling Precautions
• The model No. you set here is for internal use by the SLP.
• Set up the Model No. and options of the SDC which it tries to set up

on the Type Setting screen of the SLP before you set up parameters
of the SDC.

• The model No. of the SDC does not change even if the type is
changed on the SLP.

E10



E11

3  -  2 Setting the Environment

Set the communications port and font on the personal computer.

1. Click icon.

The operation is the same by selecting the [Option] → [Environment Setting]
command or the [Ctrl]+[E]keys.

>>The Environment Setup dialog box appears.

2. Set the communications port.

Select the various settings.

3. Set the font size.

Select the various settings.

4. Click [ OK]button.

Handling Precautions
• Normally, use “Port COM1”.

Even if another communications port can be selected, it sometimes
cannot be used depending on its shape of connector.
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3  -  3 Key Assignment

Assign the PARA key of SLP-C20. (Assign the UF key in SLP-C30.)

Select the [Option] → [Para Key Assignment]command.

>>The Para key assignment dialog box appears.

● Assign the parameter
Drag the parameters to be registered out of the items in the Unregistered

parameters to the Registered  parameters.  Registration can be canceled by double-

clicking the selected item or by pressing the [space] key.

● Cancel the parameter
Drag the parameters to be canceled out of the items in the Registered parameters

to the Unregistered parameters.  Registration can be canceled by double-clicking

the  selected item or by pressing the [space] key.



3  -  4 File Operations

■ Making new files
1. Click icon.

The operation is the same by selecting the [File] → [New] command or the

[Ctrl]+[N]keys.

>>The New dialog box appears.

2. Click [OK]button.

>>A new file opens.

■ Opening existing files
1. Click icon.

The operation is the same by selecting the [File] → [Open] command or the

[Ctrl]+[O]keys.

>>The opens dialog box appears.

2. Select the folder name in [Look in:].
3. Click (select) the file name.

4. Click [Open]button.

>>The file having the name that you set opens.

■ Overwriting and saving files
1. Click icon.

The operation is the same by selecting the [File] → [Save] command or the

[Ctrl]+[S]keys.

>>The file is overwritten and saved.

E13
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■ Saving files with a new name
1. Select the [File] → [Save As] command.

The operation is the same by selecting the [Ctrl]+[A]keys.

>>The Save As dialog box appears.

2. Select the folder name under [Save in].
3. Enter the file name to [File name].
4. Click [Save]button.

>>The file is saved under the file name that you set.

Note
• The file is overwritten and saved when you click (select) the file name at the

file name window.

■ Outputting CSV format files
1. Select the [File] → [CSV Out] command.

The operation is the same by selecting the [Ctrl]+[X]keys.

>>The CSV Output dialog box appears.

2. Select the folder name under [Save in].
3. Enter the file name to [File name].
4. Click [Save]button.

>>The file is output under the file name that you set.

Note
• The file is overwritten and saved when you click (select) the file name at the

file name window.

A CSV format file is a text file delimited by commas, and can be used in

Microsoft Excel or other off-the-shelf spreadsheet applications.



3  -  5 Communications with the SDC

■ Communicating to the SLP from the SDC (reading to SLP)
1. Click icon.

The operation is the same by selecting the [Communications] →
[Read(SDC→SLP)] command or the [Ctrl]+[R]keys.

>>The Confirm dialog box appears.

2. Click [OK]button.

>>Reading to the SLP starts.

■ Communicating to the SDC from the SLP (writing from SLP)
1. Click icon.

The operation is the same by selecting the [Communications] →
[Write(SLP→SDC)] command or the [Ctrl]+[E]keys.

>>The Confirm dialog box appears.

2. Click [OK]button.

>>Writing to the SDC starts.

Handling Precautions
• If the type set on the SLP does not match the SDC model No., the

Warnning dialog box appears on the screen.
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3  -  6 Setting Up Data
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■ Selecting setup items

● Moving the highlight section on the display by operating the keyboard
1. Press the [→], [←], [↑] or [↓]key to move the highlighted section on screen.

● Moving the highlight section on the display by operating the mouse
2. Click the section you want to move.

3. Click the scroll bar to scroll the screen.

>>The screen cannot be scrolled beyond the topmost or bottommost rows on

screen.

● Changing operation windows
1. Press the [Tab] key.

>>The screen moves to the target operation window.

Note
• Setup items are moved to in order on screen.

■ Entering numerical data

● Entering numerical values
• To enter a numerical value

Press the [0] to [9] keys on the keyboard.

• To enter a hexadecinal value

Press the [0] to [9] keys and the [A] to [F] keys on the keyboard.

• To enter a decimal point

Press the [. ] key at the desired decimal point position.

• To enter a minus value

Press the [-] key.

• To cancel a wrong entry

Press the [Back Space] key.

>>The currently displayed value is deleted.

• To cancel the currently entered numerical value

Press the [Esc] key.

>>Original set value is redisplayed.

● Select the setup item
Entering numerical data by the [0] to [9] keys to select the setup item.

1. Select the setup item to highlight it.

2. Enter the desired set value by the[0] to [9] keys.

3. Press the [Enter] key.

The operation is the same by pressing the [↑] or [↓] key.

>>The set value is fixed.
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Note
• After you have fixed the numerical value by pressing the [↑] or [↓]key, the

highlight section moves on screen.

• When you have moved a setup item using the mouse, the set value is not

fixed.

• When a set value is invalid, the original set value is redisplayed.

• To cancel a set value midway during entry, press the [Esc]key before you fix

the set value.

● Selecting and entering data

Note
• Items that can be selected and entered are automatically displayed.

1. Press a setup item button.

The operation is the same by selecting the [Tab] or [Alt]+[↓] keys.

>>[Selection Item] is displayed.

2. Select the setup item by the mouse.

The operation is the same by selecting the[→], [←], [↑] or [↓]key, or the

[Enter]key.

>>The set value is fixed.

Note
• When you use the mouse, the set value is fixed at the same time that you

select it with the mouse.



3  -  7 Mode Change (SLP-C30)

E18

■ Change the mode of SDC30/31 (SLP-C30)

● Change Auto/Manual
Click [Auto/Manual]button.

>>LED is lit when the controller is in manual operation.

● Change Run/Ready
Click [Run/Ready]button.

>>LED is lit when the controller is in ready mode.

● Start/Stop Auto tuning
Click [Auto tuning]button.

>>LED is lit when auto tuning is in operation. 

● Change Local SP/Remote SP
Click [Local/Remote]button.

>>LED is lit when the controller is in remote SP mode.

● Start/Stop automatic adjustment of Modutrol motor
Click [Start/Stop]button.

>>LED is lit when modutrol motor automatic adjustment is in operation.
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■ Communications error messages

■ File error messages

■ Startup error messages
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Category Message Description Remedy

Communication Time out. The message cannot be received Check the cable connections and
error within a period of the time-out time. contacts.

An instrument other than SDC. Use the loader with it connected to
The main unit is not connected. SDC.

Cannot open communications port. The communication port cannot be Do not run the loader and other 
opened. application using the communication 

port at the same time.

Communications error has The system error occurs. Re-operate or quit the loader to
occurred. restart Windows.

SDC status Cannot support currently The loader currently in use is not Contact Yamatake Corporation or
error connected SDC20/21 SDC30/31. applicable to the version of the main its dealer.

unit.

Category Message Description Remedy

File name This filename is not valid. An invalid file name is input. Input a correct file name.
error

This file cannot be found. A file name not existing is input. Input an existing file name.
Make sure that the correct path
and filename are given.

This filename is a reserved A file name reserved for the device Input a correct file name.
device name. name is input.
Use a different filename.

Disk error Not enough free space on disk. The disk free capacity is insufficient. Keep a sufficient disk free capacity.

The device is not ready. The disk is not ready. Prepare the disk and restart the 
operation.

Cannot make file. The CD-ROM is specified as save Save the file to another directory.
destination.

File name too long. The file name is too long. Use 256 characters or less for the
file name.

Path name The path does not exist. An illegal path name is input. Input a correct path name and 
error Make sure that the correct path is restart the operation.

given.

File information Illegal file size. The file is corrupted. Corrupted file cannot be used.

error Illegal file information. Create a file again.

Category Message Description Remedy

Loader system Can't start up two or more SLP- Two or more loaders are started at Click [OK] button.
error C20/C30 at once. the same time.
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